在加华人网 - ZaiCanada.com

 找回密码
 立即注册

扫一扫,访问微社区

搜索
热搜: 活动 交友 discuz
查看: 84|回复: 0

【阿里云 Ubuntu18.04安装ERPnext-2020年】

[复制链接]

349

主题

400

帖子

1168

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
1168
发表于 2020-6-9 10:16:33 | 显示全部楼层 |阅读模式
【时间】2020年,我用了阿里云的T5,1C 2G 40GB,新用户才3年189元,创业不易能薅羊毛尽量,3年又3年。
【建议配置】2 GB RAM,1 个 vCPU,40 GB SSD
【硬件要求】2G以上,平时运行也要1G
【环境要求】
• Python 3.6+
• Node.js 12
• Redis 5                                                (caching and realtime updates)
• MariaDB 10.3 / Postgres 9.5                 (to run database driven apps)
• yarn 1.12+                                                   (js dependency manager)
• pip 15+                                                       (py dependency manager)
• cron                                                                            (scheduled jobs)
• wkhtmltopdf (version 0.12.5 with patched qt)     (for pdf generation)
• Nginx
【需要理解好框架】
sudo pip的bench为了能让用户安装一个自己的bench ,
用户用bench创建了一个工作平台frappe-bench,里面可以安装APP,这些APP都需要frappe做基础,有了这个基础,就能运行erpnext、bench manager等等app
【服务器准备工作】
【必须打开端口】 11000 12000 13000 8000 9000 6379  
【按需求开端口】82  #给Bench Manager用
                         1080  #给梯子用
【梯子,按需求安装,服务器在国外不需要安装】
【shadowsocks的IP/端口账户/密码来配置 /etc/shadowsocks.json】这个账户需要自己去购买,也有免费的,但是国内基本屏蔽了。配置的用法在上一条链接中可查到。
【说明:服务器安装shadowsocks-libev后,用proxychains代理出去。】proxychains的用法是在你原来的命令前加上proxychains ,就会启用代理网络。
【开始正式安装】------------------------------------------
【系统更新】
# sudo apt-get update
# sudo apt-get upgrade \\更新授权选择yes
【安装git】
# sudo apt-get install git
【Python3安装【重要】】
# sudo apt-get install python3-dev
# alias python=python3   \\指定默认Python版本为Python3
【从下面开始,建议要新用户安装,】
# 新用户目录再home里面,新用户有sodu权限。
【安装pip3】
# sudo apt-get install python3-setuptools python3-pip
# sudo pip3 install --upgrade pip   \\更新pip3
【wkhtmltopdf的安装】【重要】
# sudo apt-get install wkhtmltopdf    \\这条安装在阿里云是默认安装0.12.4,打印会有问题,如显示{{body}}。外国服务器会默认最新。
如用bench用户进行安装,用sudo命令。
这里用root用户进行安装,如下
# cd ~    \\打开root的目录
# sudo apt-get install -y software-properties-common
# sudo apt-add-repository -y "deb http://security.ubuntu.com/ubuntu xenial-security main"   \\不换源的话,阿里云没有wkhtmltox_0.12.5-1.xenial_amd64指定要的库libpng12-0,
# sudo apt-get -yq update
# sudo apt-get install -y libxrender1 libfontconfig1 libx11-dev libjpeg62 libxtst6 fontconfig xfonts-75dpi xfonts-base libpng12-0   \\安装wkhtmltopdf需要的库
【wkhtmltopdf下载】
# wget "https://downloads.wkhtmltopdf.org/0.12/0.12.5/wkhtmltox_0.12.5-1.xenial_amd64.deb"
# 可用下载命令网速慢,自己去官方下载安装包,再放到root的目录里面。
# dpkg -i wkhtmltox_0.12.5-1.xenial_amd64.deb
# sudo apt-get -f install   //到这里完成安装wkhtmltopdf
----------------------------------------------------安装参考:
【wkhtmltopdf能解决问题的安装】https://discuss.erpnext.com/t/v1 ... n-pdf-view/54279/24
【大bug】PDF shows only {{ body }}
---------------------------------------------------解决参考:
这里要修数据库的,慎用!
【安装数据库MariaDB 10.3】
# sudo apt-get install software-properties-common
# sudo apt-key adv --recv-keys --keyserver hkp://keyserver.ubuntu.com:80 0xF1656F24C74CD1D8
# sudo add-apt-repository 'deb [arch=amd64,arm64,ppc64el] http://mirrors.tuna.tsinghua.edu.cn/mariadb/repo/10.3/ubuntu bionic main'
# sudo apt update
# sudo apt install mariadb-server    \\输入两遍数据库管理密码
【mysql】
# sudo apt-get install libmysqlclient-dev
【配置MySQL】
# sudo nano /etc/mysql/my.cnf
【修改以下内容】
[mysqld]
character-set-client-handshake = FALSE
character-set-server = utf8mb4
collation-server = utf8mb4_unicode_ci
[mysql]
default-character-set = utf8mb4
【重启MariaDB】
# sudo service mysql restart       \\重启服务
【安装Redis】【重要】
# sudo apt-get install redis-server
报错:配置文件里面屏蔽ipv6端口即可,重启Redis服务。
# vim /etc/redis/redis.conf
按 i 进入编辑
下滑倒bind 127.0.0.1 ::1
屏蔽一下  # bind 127.0.0.1 ::1
增加ipv4的   bind 0.0.0.0
【重启redis-server】
【安装node.js 12】
# sudo apt-get install curl
# curl -sL https://deb.nodesource.com/setup_12.x | sudo -E bash -
# sudo apt-get install -y nodejs
【安装yarn】
# sudo npm install -g yarn
【安装bench】
# sudo pip install -e ./bench      \\使用pip编译bench
# bench --version    \\检查bench版本
提示:非用户工作目录,无视他,后面安装好。
【安装Nginx】
# sudo apt-get install nginx
# bench setup nginx
# rm -f /etc/nginx/sites-enabled/*
# sudo ln -s ./config/nginx.conf /etc/nginx/sites-enabled/frappe.conf
# sudo service nginx restart
以非root用户身份安装Bench 【这里的Bench是安装自己的bench】
# git clone https://github.com/frappe/bench bench-repo
# pip install --user -e bench-repo     \\会创建一个文件夹bench-repo,
                                                             也可以创建为  .bench 隐藏目录。
【安装frappe框架的基准目录】
init命令将创建一个安装了frappe框架的基准目录。
它将设置为每天一次定期备份和自动更新
# bench init frappe-bench && cd frappe-bench
【创建新站点】【站点为site1.local,建议改为网站域名】
# bench new-site site1.local
【安装APP frappe】
# bench get-app frappe https://github.com/frappe/frappe
【安装APP erpnext】
# bench get-app erpnext https://github.com/frappe/erpnext
【将APP安装到站点里面去】
# bench --site site1.local install-app erpnext
【启动bench】
# bench start
【切换APP版本】
记得别用开发版,APP安装好后,立刻切换成下面版本,
ERPNext: v12.X.X(version-12)
Frappe Framework: v12.X.X (version-12)
【frappe切换为12版本的分支】
# bench switch-to-branch version-12 frappe --upgrade
不更新
# bench switch-to-branch version-12 frappe
【erpnext切换为12版本的分支】
# bench switch-to-branch version-12 erpnext --upgrade
不更新
# bench switch-to-branch version-12 erpnext
【自动更新开启/关闭】
# bench config auto_update off
# bench config auto_update on
--------------------------------------------
【常规报错解决】
[4/4] Building fresh packages...
[-/3] ⠂ waiting...
[2/3] ⠂ cypress
error /home/bench/frappe-bench/apps/frappe/node_modules/node-sass: Command failed.
解决:进去APP文件夹里面解决。
1> cd: ./apps/frappe
2> 命令$ yarn install
3> Run bench start
【一般是目录问题较多】
home/bench/.bench  \\.bench目录是首样
home/bench/frappe-bench  \\才是工作目录  #pip install --user -e frappe-bench #这个目录是这样出来的
home 、bench目录权限 777
然后单独安装app  frappe 切换12版本,单独安装app erpnext 切换12版本
不要一步就安装erpnext 下来,因为带过来的frappe可能是开发版,且时间很长,容易出错。
【安装参考资料】
https://blog.csdn.net/CAU_Ayao/article/details/83502880
https://frappe.io/docs/user/en/installation
https://github.com/frappe/bench_manager
http://www.linuxdiyf.com/linux/13645.html
有使用过ERPNext这款开源ERP系统的吗? - 梁海川的回答 - 知乎



回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

小黑屋|手机版|Archiver|在加华人网  

GMT-8, 2020-7-5 15:51 , Processed in 0.025257 second(s), 29 queries .

Powered by Discuz! X3.4

Copyright © 2001-2020, Tencent Cloud.

快速回复 返回顶部 返回列表